Omnia.11 v1.5 Software Update


Your Omnia.11 must be running version 1.5 or higher to update to version 3.x

Version 1.5 was released in 2014 as a compact flash card update. This new CF card is required in order to update to version 3.x.

If your unit is running version 1.4 or earlier, please contact Telos Support to obtain the necessary compact flash card(s) and instructions.



Return To