Omnia.11 v3.0.2 Software Update (v1.5 or higher required)


**note** Software v1.5 or higher is required in order to update to v3.0.2

Please find the software v3.0.2 download here 

Please find the release notes for this version here 

 



Return To